How to Install Data Analysis and Solver ToolPak's in Microsoft Excel

Windows

To install the Analysis ToolPak Add-in in Excel 2016/2019 follow these steps.

  • Click on file.

  • Click on Option. You'll see the excel options dialogue box.
  • Click on Add-Ins. It is on the left, second option from the bottom.
  • Locate Analysis ToolPack and click on it.
  • In the bottom, you must be able to see manage drop down. Select Excel-Add-ins and click on Go button.

  • All available Add-ins will be shown to you. Check Analysis Toolpak and click OK.

Analysis ToolPak is added now. You can see it in the Data tab.

Mac

To install Analysis Toolpak in Excel for Mac, follow below steps.

  • In Excel go to the Tools menu at the top of your screen.
  • Locate and select Excel Add-Ins.
  • You'll be prompted to choose from available add-ins. Select Analysis Toolpak.
  • Click Ok.

Analysis Toolpak is added. Go to the Data tab, in the rightmost corner you'll find Analysis Toolpak waiting for you.